SendGrid Email Delivery Delays

Incident Report for FRONTSTEPS

Monitoring

SendGrid has reported continued improvement with lower deferrals and fewer blocks, and we’ve seen messaging performance return to normal. We had very limited reports throughout the event and no new issues have been reported. Both SendGrid and our team will continue monitoring to ensure continued stability.
Posted Jan 28, 2026 - 18:48 MST

Investigating

We’re seeing delayed or intermittent email (and sometimes SMS) delivery due to SendGrid instability. Our engineers are working with SendGrid to restore normal messaging. If it can wait, please hold notifications until SendGrid fully resolves the issue: https://status.sendgrid.com/.
Posted Jan 27, 2026 - 12:41 MST
This incident affects: FRONTSTEPS Caliber (Email Service).